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Version follow up 

 
V0.6 – 30/08/2012 

• Implement code to exploit Polycom IP Phones data disclosure vulnerability (OSVDB-
ID: 73117). 

• Implement code to exploit Polycom IP Phones DoS through web interface (OSVDB-
ID: 70697). 

• Implement a module to detect Polycom SoundPoint IP Phones use of default 
Login/password and unprotected web interface. 

• Add the capacity to scan a full subnet for Aastra & SNOM default login/password 
search. Capacity to save results in text files has been added also. 

• Add an integrated graphical module for Protos SIP in ISME (need java to work). 
• Cisco phone ringer & forwarder support new types of IP Phone: 

7914,7915,7916,7920,7921,7925,7985 
• Due to some problems met by users at the installation, I finally come back to an install 

process mainly based on CPAN.  
 
V0.5 – 06/08/2012 

• Add SIP Flooding attacks (Invite, Register, Options) 
• Add TCP SYN Flood attack 
• Update installer 
• Change menu presentation 

 
V0.4 – 12/06/2012 

• Add Cisco phone attacks (ringer & forwarder – skinny) 
• Add Lan & Servers attacks (DHCP Starvation & DNS Subnet resolver) 

 
V0.3 – 12/02/2012 

• All kind of subnets are now support. ISME is no more limited to “/24”. Take care, it is 
done with the utilization of a new library. Be sure to install it (or load the installation 
script which add been adapted) before launching this new version. 

• Add the capacity to detect default password on SNOM IP Phones. 
 
V0.2 – 03/01/2012 

• Add an installer for all the perl modules. 
• Add the capacity to detect default password on Aastra IP Phones. 

 
V0.1 – 20/12/2011 
First release of ISME script. 
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Introduction 

 
Initially intended as a scanner dedicated to Cisco IP Telephony solution, ISME has evolve in 
a small framework to test IP Phones from several editors. 
 
Nevertheless, the four goals I had in mind at the beginning are still present: 

• Provide a simple tool to use, 
• Trying to create something new dedicated to ip telephony, 
• Targeting  enterprise solutions, 
• Exploiting LAN connexion possibilities. 

 
Cisco target 
Thus my first target was Cisco IP Phone. The embedded Cisco IP Phone web server makes it 
an easy target full of interesting stuff. Moreover, the piece of information collected should 
render feasible the possibility to get the phone’s config file directly from TFTP server. 
Indeed, it is much easier once we do know the name of the file. Brute forcing TFTP is just not 
really convincing. Trying to get it with proper name is truly effective. You will find in annex 
A of the document a sample of the config file. It should help you consider how interesting it 
could be to get this file. 
 

 
 
Other equipment offer less possibilities but could nevertheless provide information such as: 

• SIP/SIPS (TCP/UDP) enable 
• Embedded web server 
• Web server banner 
• Editor identification through Mac address 
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What else? 
 
ISME is now able: 

• To identify default login/password for SIP phones (Polycom, Aastra, SNOM), 
• Implement attack dedicated to Cisco Phones, 
• Implement different server side attacks, 
• Specific code to implement exploits, 
• Add GUI for external fuzzers to provide a complete set of tools. 
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1- A quick comparison with existing scripts 

 

ISME NMAP
SVMAP 

(sipvicous)

SVWAR 

(sipvicous)

SVCRACK 

(sipvicious

)

SIPVICOUS SMAP Metasploit

Scanning options

GUI interface Y Y N N N N N Y

CLI interface N Y Y Y Y Y Y Y

Detect SIP port over UDP Y Y Y N N Y Y Y

Detect SIPS port over UDP Y Y Y N N Y ? Y

Detect SIP port over TCP Y Y N N N N ? Y

Detect SIPS port over TCP Y Y N N N N ? Y

Identified web server presence Y Y N N N N N N

Grab web server banner Y Y N N N N N N

Web server brute forcing Y N N N N N N N

Got SIP user agent information N NSE ? Y N N Y Y Y

Got SIP Options N NSE ? Y N N Y Y Y

Brute force SIP Password on 

extension N N N N Y Y N N

Find active phone number /SIP 

wardialing N N N Y N Y N Y

Resolve device editor through 

mac@ Y ? N N N N N N

Identified clearly Cisco IP Phone 

model Y Depend N N N N N N

Get applicative informations of 

Cisco IP Phone Y N N N N N N N

Get infrastructure server 

information used by Cisco IP 

Phone Y N N N N N N N

Get Cisco IP Phone config file on 

TFTP server Y N N N N N N N

Save the results Y Y Y Y Y Y ? ?

Reload result for analysis Y Y N N N N ? ?

Filtering the result to focus on 

specific item Y N N N N N N ?

SNOM brute force Y N N N

Polycom brute force Y N N N

Aastra brute force Y N N N

SIP Fuzzing (Protos embedded) Y N N N

SIP Invite flooding Y NSE ? N N

SIP Options flooding Y NSE ? N N

SIP Register flooding Y NSE ? N N

DHCP Starvation Y N N N

TCP Syn flood Y N N N

DNS Subnet resolver Y N N N

Other tools

N

N

N

N

N

N

N

N

N

N
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2- Working environment 

2.1- Dev environment 

2.1.1- Library 

ISME has been developed in Perl. Thus it should run on nearly every operating system 
running perl. 
 
The following libraries are needed: 

• LWP::UserAgent; # http://search.cpan.org/~gaas/libwww-perl-
6.03/lib/LWP/UserAgent.pm 

• HTML::Parser; # http://search.cpan.org/dist/HTML-Parser/Parser.pm  
• Net::Ping; # http://search.cpan.org/~smpeters/Net-Ping-2.36/lib/Net/Ping.pm 
• Net::Netmask; # http://search.cpan.org/dist/Net-Netmask/ 
• Net::Subnets; 
• Net::TFTP; # http://search.cpan.org/~gbarr/Net-TFTP-0.16/TFTP.pm 
• Net::DHCP::Packet; # http://search.cpan.org/~djzort/Net-DHCP-

0.69/lib/Net/DHCP/Packet.pm 
• Net::DHCP::Constants; # http://search.cpan.org/~djzort/Net-DHCP-

0.69/lib/Net/DHCP/Constants.pm 
• Net::Libdnet::Arp; 
• Crypt::SSLeay; #http://search.cpan.org/~nanis/Crypt-SSLeay/SSLeay.pm 
• LWP::Protocol::https ; #http://search.cpan.org/~gaas/LWP-Protocol-https-

6.02/lib/LWP/Protocol/https.pm 
• Mozilla ::CA;#s http://search.cpan.org/~abh/Mozilla-CA-

20111025/lib/Mozilla/CA.pm 
• HTTP::Request::Common; # http://search.cpan.org/~gaas/HTTP-Message-

6.02/lib/HTTP/Request/Common.pm   
• Net::Subnets 
• Tk; #http://search.cpan.org/~ni-s/Tk-804.027/pod/UserGuide.pod 
• Net::RawIP; #http://search.cpan.org/~saper/Net-RawIP-0.25/lib/Net/RawIP.pm 

Take care, even if libraries are not explicitly declared in the script, there are needed 
nonetheless. 
 
Java must be installed on the computer if you intend to use Fuzzing SIP – Protos. 
 

2.1.2- Threads  

Threads must be activated for Perl. If it’s not the case some tools won’t be working. To verify 
the threads status, enter “perl –V” in a terminal. If you find “useithreads=undef” in the 
answer, you must recompile your perl version with threads option. 
 
Note: installing thread modules from CPAN won’t change the situation. 
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For those who are working on a MAC, with mac port tool, enter the following command in a 
terminal: “sudo port install perl5 +threads”. It should do the trick.  
 

2.1.3- Tested operating system  

 
The following operating systems have been tested as working with version 0.6: 

• Macosx 10.6.8 
• BackTrack 5 R3 

I would welcome any information on deployment on other Linux flavor (isme_sec@yahoo.fr) 
. 

 
 

2.2- Installing perl modules 

 
Since there are many perl modules to install in order to have a working ISME script, I put 
some of them in the directory “PerlModuleSource” with a proper script either to compile or 
get them through CPAN. Root level and Internet connection are mandatory. 
- User has the choice to install them by himself or with the above procedure - 
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Note:  
Net::Libdnet needs libdnet library. It can be download from http://libdnet.sf.net. 
If the installation is needed the following error message should appear : 
Libdnet.xs:37:18: error: dnet.h: No such file or directory. 

 

2.3- Directory structure of ISME 

 
CiscoIpPhoneConfigFile: directory containing the phones configuration files obtained 
through TFTP. 
 
Doc: directory containing documentation. No surprise. 
 
Exploits: contain scripts exploiting specific weakness. 
 
Isme_data: containing file needed for a proper running of ISME. 
 
PerlModuleSource: sources for specific perl modules needed for ISME. Work in correlation 
with “installPerlModulev0.5.sh”. 
 
Scan_history: directory containing all the results of all scans (automatically generate at the 
end of the scan). Files in this directory could be erased by hand or through ISME interface 
(menu “History->Delete saved scans”). 
 
Tools: containing perls script for the tool menu. 
 
User_data: default directory for the saved file of the user. 
 

2.4- Where to get the script 

 
ISME is host on freecode web portal. Here is the project url:  
http://freecode.com/projects/ip-phone-scanning-made-easy-isme  
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3- Launching ISME 

 
WARNING: ISME need to be run as root, hence the sudo below. 
 

1. Open a terminal 
2. Go to the directory containing isme.pl 
3. Enter the following command “sudo perl isme.pl” 

 

 
 
This should launch a GUI interface as described in next page. 
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4- Scanner tool 

4.1- The Graphical User Interface 
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4.2- How to launch a new scan? 

 
The procedure is simple enough: 

1- Enter the subnet with following syntax: 192.168.1.0/24 
2- Launch the scan through the menu File->Launch scanning 

 

 
 
Three limitations are presents right now: 

• Any subnet you wish as long as it has de correct syntax X.X.X.X/XX 
• Nothing can be done while the script is scanning, 
• Scanning a subnet could take 25 to 30 minutes from my own experience. 

 
It should be overcome in future versions. Yes I may be able one day to work out how to 
develop proper multithreading… 
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4.3- Exploit the scan results 

4.3.1- Understand the interface and the basics 

 
The results of the scan will exploit all part of the GUI. Upper window (step 0) will contain 
raw logs. By raw I mean that positive and negative results are present. 
 
Left lower part (step 1) will contain all the IP addresses that have been found active. 
 
Right lower part (Step 3) will contain the information specifically link to an IP address. To 
have them, the ip address must be selected and validated with the button “show details of 
selected IP address” (Step 2). 
 

 
 

4.3.2- Smarter input 

 
Unified communication servers are often configured through web server. Those ones are 
letting some informations sleep out, which permit to identify some of them. When a proper 
identification is realize, it appears as SMART INPUT in the windows log. 
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The following servers could be identified today through “smarter input”: 

• Alcatel-Lucent OmniVista 4760 NMS 
• OmniPCX for Enterprise 
• Alcatel-Lucent OmniTouch 8660 
• Alcatel-Lucent Omnitouch 8400 
• Cisco Unified Contact Center Express 
• CISCO Codec 
• Codian MCU 
• Aastra Management 7450 
• Cisco Unified Communications Manager 
• Cisco Unified Presence 
• Cisco Unity Connection 
• VMware ESX Server 
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4.4- Filtering 

 
Ok, so we have some result, we can select an ip address to see some stuff, but how could I 
find an information and sort it out for 250 IP Phones ? Well, through the filtering functions. It 
will provide the capacity to sort out result in the log windows (upper ones). Here are the 
filters that are available today: 

• SIP UDP/TCP 
• SIPS UDP/TCP 
• Embedded web server 
• Cisco IP phone 
• See all logs (print raw information in log windows again) 

 

 
 
Those filters help to sort out the information to go deeper in details if need be. 
 
Filter results can be saved in a text file through menu “File->Save logs”. The default location 
of the saved file is in user_data directory. 
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4.5- Reload an old scan 

 
Completed scans are automatically saved in the directory “scan_history”. The syntax of files 
is the following: year-month-day-time-scanned network.isme. It is a texte file even I the 
extension is “.isme”. 
 
By going in menu “history-> open saved scan”, those files could be reload in ISME for 
further analysis. 
 

 
 

4.6- Cisco IP Phones already tested 

 
The script has been found working on the following Cisco IP Phone models: 

• CP-7942G test OK. English interface. 
• CP-7961G test OK. English interface. 
• CP-9971  test OK. English interface. 
• CP-7971G-GE test OK. English interface. 
• CP-7985 test PARTIAL. English interface.s 
• CP-7975G test OK. French interface. 
• CP-7970G test OK. French interface. 

 
 
 
 
  



ISME v0.6 

Date : 31/08/2012 By Cedric Baillet Page 19 
 

5- Tools: IP Phone web server default password identification 

5.1- Introduction 

 
Many SIP IP Phones have an embedded web server to work on their configurations. Basic 
authentication is the usual way to get in. The idea of this module is to test those web servers 
with the usual default passwords of major editors. 
 
The attack could be done in three ways: 

- The attack is launched on the current load subnet scan. It will analyze it to get all the 
devices with a web server and launch the test. 

- The attack could be launch on a single IP address 
- The attack could be launch on a specific subnet. 

 
More editors should come with other versions and opportunities to find devices. 
 

5.2- Aastra IP Phones 

 
Step 1: Menu “Tools->Default log: Aastra IP Phone”. A new window will open. 
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Step 2: Chose your scanning option  

 

IP Phone from scanned subnet: this option will use the results of a global scan done earlier 
to extract unidentified active IP address with an associate web services. It will then test it for 
Aastra default login/password. 

Once the option is selected, it is necessary to load the file containing older scan result. It is 
done through the menu  “File ->“Select subnet to load”. 

 

A new pop up will appear. Browse the directory and select the file. 
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Single IP Phone: This option will test only one IP address. 

 

Scan a subnet: this option will scan a full subnet and test all active IP address (evaluate 
through a ping). Subnetting is supported. 

 

Step 3: launch the test itself. Menu “File” -> “Launch brute force attack” 

 

Step 4: analyze the results. 
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Step 5: Results can be saved in a text file for later analysis. Just go to “File->Save scan 
results”. 
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5.3- SNOM IP Phones 

 
Step 1: Menu “Tools->Default log: SNOM IP Phone”. A new window will open. 
 

 
 
Steps 2 to 5 are identical to 5.2 with Aastra phones. Please refer to it. 
 
Note: SNOM IP Phones have different default login/password depending on models and 
versions. The following couples are currently tested: 

• administrator/0000 

• admin/admin 
• administrator/0000 

• -/0000 
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5.4- Polycom SoundPoint  IP Phones 

 
Step 1: Menu “Tools -> Default log: Polycom SoundPoint  IP Phone”. A new window will 
open. 

 
 
Step 2: Select if you want to realize a subnet scanning or a single IP address scan and enter 
the subnet (ie: the IP address depending of your choice). 
 

 
 
Step 3: Select menu “File” -> Launch brute force attack” to launch the attack. 
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Note: Polycom soundpoint web server could be protected by authentication in different 
manners. By default, only specific web pages are protected. In this case, the message “No 
login/password set to access the main web gui – WARNING”  will appear. The obvious 
counter measure is configuring a global authentication. 
 
Step 4: Save the result 
Select menu “File -> Save scan results”. 
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6- Tools: Cisco IP Phone attacks 

6.1- Cisco phone ringer 

6.1.1- Concept 

Idea: taking the identity of a skinny cisco phone, and use it to register with the CUCM and 
make the other phones ringing. 
 

 
 

6.1.2- Using ISME to do it 

 
Note: The attack does not depend of earlier scans made with ISME. 
 
Supported IP Phone models: 6901, 6911, 6921, 6945, 6961, 7910, 7911, 7912, 7940, 7941, 
7942, 7945, 7960, 7961, 7962, 7965, 7970, 7971, 7975, 8941, 8945, 8961 
 
To launch the attack interface, go to menu “Tools -> Cisco Phone: Ringer (SCCP)” 
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A new window will open with information to provide. They are a necessity to be able to spoof 
the identity of a working IP Phone. Be precise or nothing will happen. 
 

 
 
Note: no control is done on user provided information. 
 
Once all information are provided, go to menu “File -> Launch ringing attack” to start the 
attack. 
 

 
 
The phones configured with the numbers provided should start to ring. Only two 
numbers are configurable to use this tool as a proof of concept and nothing else. 
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Screen after a successful attack: 
 

 
 
  



ISME v0.6 

Date : 31/08/2012 By Cedric Baillet Page 29 
 

6.2- Cisco phone forwarder 

6.2.1- Concept 

 
Idea: Spoofing the identity of a skinny cisco phone, and use it to register with the CUCM and 
set a forward on it. 
 

 
 

6.2.2- Using ISME to do it 

 
Note: The attack does not depend on earlier scans made with ISME. 
 
Note 2: after the attack the real physical phone will be in an unstable state for around one 
minute. We have spoofed his identity to change the configuration of CUCM, therefore he 
need to resynchronize with him. 
 
Supported IP Phone models: 6901, 6911, 6921, 6945, 6961, 7910, 7911, 7912, 7940, 7941, 
7942, 7945, 7960, 7961, 7962, 7965, 7970, 7971, 7975, 8941, 8945, 8961 
 
To launch the attack interface, go to menu “Tools -> Cisco Phone: Forwarder (SCCP)” 
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A new window will open with information to provide. They are a necessity to be able to spoof 
the identity of a working IP Phone. Be precise or nothing will happen. 
 

 
 
Note: no control is done on user provided information. 
 
Once all information are provided, go to menu “File -> Launch forwarding attack” to start the 
attack. 
 

 
 
The spoof IP Phone should restart and have a set forward to the chosen number. 
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Screen after a successful attack: 
 

 
 
 

6.3- Counter measure 

 
Attacks described in 6.1 and 6.2 are all based on the capacity to spoof IP Phones identity. A 
strong authentication with a certificate, either MIC or LCS, will render those attacks 
unsuccessful. 
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7- Tools: LAN & Servers  

 
The core infrastructure providing services to IP Phone is highly sensible and the smaller 
interruption of one server can have a huge impact on the whole panel of IP Phone. Therefore, 
it should be test extensively. This new rubric aims at consolidate existing attacks in one place. 
 

7.1- DHCP Starvation 

7.1.1- Concept 

DHCP Starvation is an old and well known attack. The aim is an attribution of all the existing 
IP address available on DHCP server and render him useless. 
 

 
 

7.1.2- Using ISME to do it 

 
Note: the script is configured to send DHCP discover with the PC MAC address at the layer 
2. This means that port security will be useless in such a configuration. Take care. 
 
To launch the attack interface, go to menu “Tools -> Server: DHCP Starvation” 
 

 
 
A new window will open. Select the number of DHCP Discover to send depending of the 
subnet size. A temporization has been included in the script. The computer sending is too fast 
for a good efficiency, which is solve with the temporization, so do not be surprised by an 
appearance of slowness. 
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To launch the attack interface, go to menu “File -> Launch DHCP Starvation attack”. 
 

 
 
The attack is straight forward. The packets will be sent and the script will stop. A clear 
message is log in the interface when this status is reach. 
 

 
 

7.1.3- Counter measure 

 
DHCP Snooping functionality verifies the coherency between layer 2 and applicative lever for 
DHCP packet. Packets sent with ISME will trigger the security rule and be discarded. 
  



ISME v0.6 

Date : 31/08/2012 By Cedric Baillet Page 34 
 

7.2- DNS Subnet resolver 

7.2.1- Concept 

 
By being plug in the LAN and having an IP address, a PC has a very effective mean to 
identify core infrastructure servers through DNS. 
 
Indeed, once a first scan has been done with ISME on IP Phone subnet, the servers’ subnet is 
known. 
 
With this information, we have just to associate active ip address with the server name 
through DNS request, which will be a serious time saving compare to a brute force attack. 
 

7.2.2- Using ISME to do it 

 
To launch the attack interface, go to menu “Tools -> Server: DNS Subnet resolver” 
 

 
 
Enter the subnet to scan. 
 

 
 
To launch the attack interface, go to menu “File -> Launch NS Resolver analyze”. 
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Analyze the results. 
 

 
 
And don’t forget to save them or you will have to do it again. 
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7.3- TCP SYN FLood 

7.3.1- Concept 

 
TCP Starvation is an old and well known attack. Nonetheless, it is still effective against 
services using TCP that are not protected by a firewall. Thus, a CUCM could be render 
useless with a simple PC through a TCP Starvation attack on signalization port. 
 

 
 

7.3.2- Using ISME to do it   

 
To launch the attack interface, go to menu “Tools -> LAN: TCP SYN Flood” 
 

 
 
Enter CUCM IP address and choose signalization port to flood. 
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Go to menu “File ->Launch TCP SYN FLOOD” 
 

 
 
To stop the flooding, use the button at the bottom of the windows. 
 

 
 
Errors are sometime coming up in the console windows. I do not know what is causing them 
yet. Nevertheless, it does not impact the attack so do not worry about it. 
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7.3.3- performance issue   

 
The script is sending an average of 7 000 packets per second on my computer. 
 
If higher performance is necessary, I would recommend to use tools written in a language that 
is not interpreted (netwox option 76 for example). 
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8- Tools: SIP Flooder 

8.1- Concept 

 

 

8.2- Using ISME to do it 

 
Step 1: To launch the attack interface, go to menu “Tools -> LANSIP Flooder (Invite, 
Options, register)” 
 

 
 
Step 2: enter the target IP address and choose SIP message type. 
 

 
 
Step 3: Launch attack with the menu “File -> Launch SIP Flood”. 
 

 
 
Step 4: sStop flooding attack, just click on the bottom button “Stop flooding”. 
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8.3- Details of crafted packets 

8.3.1- SIP Invite packet 

 

 
 
Source IP address is random for each packet. 
 

8.3.2- SIP Options packet 

 

 
 
Source IP address is random for each packet. 
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8.3.3- SIP Register packet 

 

 
Source IP address is random for each packet. 
 

8.4- performance issue 

 
The script is sending an average of 16 000 packets per second on my computer. 
 
If higher performance is necessary, I would recommend to use tools written in a language that 
is not interpreted (sipsak for options flooding for example – sipsak.org). 
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9- Tools: SIP Fuzzers 

9.1- Concept 

Fuzz testing or fuzzing is a software testing technique, often automated or semi-automated, 
that involves providing invalid, unexpected, or random data to the inputs of a computer 
program. The program is then monitored for exceptions such as crashes, or failing built-in 
code assertions or for finding potential memory leaks. Fuzzing is commonly used to test for 
security problems in software or computer systems. 

9.2- PROTOS SIP 

 
Protos can be found at the following url: 
https://www.ee.oulu.fi/research/ouspg/PROTOS_Test-Suite_c07-sip 

9.2.1- Test case details 

 
Legend:  

• "Name" column represents the tag-names of the test-groups. Tags reflect the header 
and field names in the protocol specification. Tags can be used to follow which parts 
of the PDU are being tested.  

• "Exceptional Elements" column describes which exceptional element categories are 
integrated in the test-group.  

• "First Index #" and "Test Cases" columns describe the first test-case number for a test-
group, and the number of cases from there on.  

Name Exceptional Elements 
First 
Index # 

Test 
Cases 

valid  n/a  0  1  

SIP-Method  
overflow-general, overflow-space, overflow-null, 
fmtstring, utf-8, ansi-escape  

1  193  

SIP-Request-URI  sip-URI  194  61  

SIP-Version  sip-version  255  75  

SIP-Via-Host  ipv4-ascii  330  106  

SIP-Via-Hostcolon  overflow-colon  436  16  

SIP-Via-Hostport  integer-ascii  452  46  

SIP-Via-Version  sip-version  498  75  

SIP-Via-Tag  sip-tag  573  57  

SIP-From-
Displayname  

overflow-general, overflow-space, overflow-null, 
fmtstring, utf-8, ansi-escape  

630  193  

SIP-From-Tag  sip-tag  823  57  

SIP-From-Colon  overflow-colon  880  16  

SIP-From-URI  sip-URI  896  61  

SIP-Contact-
Displayname  

overflow-general, overflow-space, overflow-null, 
fmtstring, utf-8, ansi-escape  

957  193  
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SIP-Contact-URI  sip-URI  1150  61  

SIP-Contact-Left-
Paranthesis  

overflow-leftbracket  1211  16  

SIP-Contact-Right-
Paranthesis  

overflow-rightbracket  1227  16  

SIP-To  
overflow-general, overflow-space, overflow-null, 
fmtstring, utf-8, ansi-escape  

1243  193  

SIP-To-Left-
Paranthesis  

overflow-leftbracket  1436  16  

SIP-To-Right-
Paranthesis  

overflow-rightbracket  1452  16  

SIP-Call-Id-Value  
overflow-general, overflow-space, overflow-null, 
fmtstring, utf-8, ansi-escape  

1468  193  

SIP-Call-Id-At  overflow-at  1661  16  

SIP-Call-Id-Ip  ipv4-ascii  1677  106  

SIP-Expires  integer-ascii  1783  46  

SIP-Max-Forwards  integer-ascii  1829  46  

SIP-Cseq-Integer  integer-ascii  1875  46  

SIP-Cseq-String  
overflow-general, overflow-space, overflow-null, 
fmtstring, utf-8, ansi-escape  

1921  193  

SIP-Content-Type  
overflow-general, overflow-space, overflow-null, 
fmtstring, utf-8, ansi-escape, content-type  

2114  247  

SIP-Content-Length  integer-ascii  2361  46  

SIP-Request-CRLF  crlf  2407  10  

CRLF-Request  crlf  2417  10  

SDP-Attribute-CRLF  crlf  2427  10  

SDP-Proto-v-
Identifier  

overflow-general, overflow-space, overflow-null, 
fmtstring, utf-8, ansi-escape  

2437  193  

SDP-Proto-v-Equal  overflow-equal  2630  16  

SDP-Proto-v-Integer  integer-ascii  2646  46  

SDP-Origin-
Username  

overflow-general, overflow-space, overflow-null, 
fmtstring, utf-8, ansi-escape  

2692  193  

SDP-Origin-Sessionid integer-ascii  2885  46  

SDP-Origin-
Networktype  

overflow-general, overflow-space, overflow-null, 
fmtstring, utf-8, ansi-escape  

2931  193  

SDP-Origin-Ip  ipv4-ascii  3124  106  

SDP-Session  
overflow-general, overflow-space, overflow-null, 
fmtstring, utf-8, ansi-escape  

3230  193  

SDP-Connection-
Networktype  

overflow-general, overflow-space, overflow-null, 
utf-8, fmtstring  

3423  188  

SDP-Connection-Ip  ipv4-ascii  3611  106  

SDP-Time-Start  integer-ascii  3717  46  

SDP-Time-Stop  empty  3763  1  
SDP-Media-Media  overflow-general, overflow-space, overflow-null, 3764  193  
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fmtstring, utf-8, ansi-escape  

SDP-Media-Port  integer-ascii  3957  46  

SDP-Media-Transport 
overflow-general, overflow-space, overflow-null, 
fmtstring, ansi-escape  

4003  118  

SDP-Media-Type  integer-ascii  4121  46  

SDP-Attribute-
Rtpmap  

overflow-general, overflow-space, overflow-null, 
fmtstring, ansi-escape  

4167  118  

SDP-Attribute-Colon  overflow-colon  4285  16  

SDP-Attribute-
Payloadtype  

integer-ascii  4301  46  

SDP-Attribute-
Encodingname  

integer-ascii  4347  118  

SDP-Attribute-Slash  overflow-slash  4465  16  

SDP-Attribute-
Clockrate  

integer-ascii  4481  46  

 

9.2.2- Using ISME to do it 

  
Step 1: To launch the attack interface, go to menu “Tools -> SIP Fuzzing – PROTOS SIP” 
 

 
 
Step 2: Enter the target IP address (one target only) 
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Step 3: Select the fuzzing method. 

- Yes (all fuzzing case): run the 4527 fuzzing case included in protos sip. 
- No (Select fuzzing cases): run only specific cases to test a particular area. 

 
Step 4: 
If the running of all the tests has been selected - Yes (all fuzzing case) - we could proceed 
with the launching. Go to menu “File -> Launch fuzzing session”. 
 

 
 
Else, it is necessary to select the test case that should be run by selecting it through the “Select 
fuzzing method” menu. 
 

 
 

Once the selection is done, launch the fuzzing through “File -> Launch fuzzing session”. 
 
Step 5: once the fuzzing session is terminated, have a look on the target to see if it’s still 
working properly… 
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Note: running a sniffer (wireshark) on your computer will provide the capacity to analyze 
what is sent and what are the answers. 
 

 
 
  



ISME v0.6 

Date : 31/08/2012 By Cedric Baillet Page 47 
 

10- Exploits 

10.1- Polycom IP Phone Web Interface Data Diclosure Vulnerability 

10.1.1- Description 

 

 
 

 
 
Note: if administrator has handled the vulnerability through work around configuration, the 
device may be still vulnerable to brute force. Do not forget to test it. 
 

10.1.2- Using ISME to exploit the data disclosure 

 
Step 1: To launch the attack interface, go to menu “Exploits -> Polycom SoundPoint IP 
Phone: Web Gui Vulnerability” 
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Step 2:  
Select either a subnet to scan or a single IP Phone. 
Enter the subnet (192.169.1.0/24) or a single IP Address (192.168.1.1). 
 

 
 
The script will try to ping the IP address as first action. If the result is positive, it will move 
forward and try to connect to the web server. Only IP Addresses that answer to ping will 
appear in the results. 
 

 
 
Step 3: Launch attack 
go to menu “File -> Launch exploit” 
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A positive result will provide UserID/Password and registrar. 
 

 
 
Step 4: Save results 
Results appear in the bottom of the user interface. Nevertheless, they can be saved to a text 
file for a later analyze. 
 
go to menu “File -> Save scan results” 

 
 
More information: 

1- A class C subnet is scanned in 25 minutes on my computer. Time depends of the 
number of found web servers and their time to answer requests. 

2- The implementation of threads may provide better performance… 
 
 

10.2- Polycom IP Phone Web Interface Denial of Service 

10.2.1- Description 
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10.2.2- Using ISME to exploit the DoS 

 
Step 1: To launch the attack interface, go to menu “Exploits -> Polycom SoundPoint IP 
Phone: HTTP Denial of Service Vulnerability” 
 

 
 
Step 2: Enter IP Address of the target 
 

 
 
Step 3: Launch attack 
go to menu “File -> Launch exploit” 
 

 
 
Step 4: wait for 60s, the device should have reboot if vulnerable. 
 

 
 
Note: If the connection to the device’s web interface is unsuccessful, an error message will 
appear. 
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ISME v0.6 

Date : 31/08/2012 By Cedric Baillet Page 52 
 

11- Features to come 

 
• Implement multi threading to gain in efficiency 
• Implement SIP UA to get: 

- SIP Option 
- SIP user agent information 

• Support ip phone 7921 (miss a proper html code analyzing), etc … 
• Implement Cisco Ringer & Forwarder in SIP 
• Voiper GUI 
• AASTRA IP phone line password. 
• Insert the capacity to stop a scan on Aastra/Polycom/SNOM brute force 
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Annex A- Limitation due to Cisco IP Phone language and how to 

overcome it 

 
Right now, ISME has been test on some French and English model of Cisco IP Phone. Since 
the informations are gathered by analyzing the HTML code, the keywords will be false if it’s 
Spanish. Nevertheless, it could be easely bypass by adding of few lines in the sub function 
“AnalyzeHTML” of ISME script. 
 
AnalyzeHTML function is mainly regular expression to find the right keyword.  
Step 1: connect to a Cisco IP Phone web interface (http://IP address) and ask for html source 
code, 
Step 2: Add a new elsif case with a copy/past 
 

 
 
Step 3: replace with the right keyword in Spanish language. Moreover, if you are an 
experience user in regular expression you may even find a better way to do the job than what 
I’ve come out with. 
 
Step 4: Do it for every item the script is looking at. 
 
Step 5: same thing as step 1 to 4 for FIND_SERVERS sub function. 
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Annex B- How is ISME determining an open UDP Port ? 

 
Determining if a UDP port is open or not is not as easy as with TCP. I am doing it by 
verifying if I get an ICMP unreachable when trying the UDP port. If it is the case the port is 
close, else, he is open or the ICMP unreachable has been filtered... 
 
There may be more effective ways but I do not know of them. Anyway, here is my code for 
further analysis.  
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Annex C- sample config file from a Cisco IP Phone 

 
<?xml version="1.0" encoding="UTF-8"?> 
<device  xsi:type="axl:XIPPhone" ctiid="45" uuid="{9ab284d7-daab-925a-9640-
90f1a000c0d4}"> 
<fullConfig>true</fullConfig> 
<deviceProtocol>SCCP</deviceProtocol> 
<sshUserId></sshUserId> 
<sshPassword></sshPassword> 
<ipAddressMode>0</ipAddressMode> 
<allowAutoConfig>true</allowAutoConfig> 
<ipPreferenceModeControl>0</ipPreferenceModeControl> 
<tzdata> 
<tzolsonversion>2011h</tzolsonversion> 
<tzupdater>tzupdater.jar</tzupdater> 
</tzdata> 
<devicePool  uuid="{378ffb5b-fd1a-b02b-dbb6-cdb27ee13202}"> 
<revertPriority>0</revertPriority> 
<name>DP_Headquarters_Video_MCU</name> 
<dateTimeSetting  uuid="{9ec4850a-7748-11d3-bdf0-00108302ead1}"> 
<name>CMLocal</name> 
<dateTemplate>D-M-Y</dateTemplate> 
<timeZone></timeZone> 
<olsonTimeZone>Europe/Paris</olsonTimeZone> 
<ntps> 
<ntp> 
<name>192.168.100.10</name> 
<ntpMode>Directed Broadcast</ntpMode> 
</ntp> 
<ntp> 
<name>192.168.100.24</name> 
<ntpMode>Unicast</ntpMode> 
</ntp> 
<ntp> 
<name>192.168.100.253</name> 
<ntpMode>Directed Broadcast</ntpMode> 
</ntp> 
</ntps> 
</dateTimeSetting> 
<callManagerGroup> 
<name>BCS</name> 
<tftpDefault>true</tftpDefault> 
<members> 
<member  priority="0"> 
<callManager> 
<name>CUCM8</name> 
<description>CUCM8</description> 
<ports> 
<ethernetPhonePort>2000</ethernetPhonePort> 
<sipPort>5060</sipPort> 
<securedSipPort>5061</securedSipPort> 
<mgcpPorts> 
<listen>2427</listen> 
<keepAlive>2428</keepAlive> 
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</mgcpPorts> 
</ports> 
<processNodeName>CUCM8</processNodeName> 
</callManager> 
</member> 
</members> 
</callManagerGroup> 
<srstInfo  uuid="{c6cba97c-3ae0-4cdc-86d7-3f285aacff05}"> 
<name>Routine</name> 
<srstOption>User Specific</srstOption> 
<userModifiable>true</userModifiable> 
<ipAddr1>192.168.100.253</ipAddr1> 
<port1>2000</port1> 
<ipAddr2></ipAddr2> 
<port2>2000</port2> 
<ipAddr3></ipAddr3> 
<port3>2000</port3> 
<sipIpAddr1></sipIpAddr1> 
<sipPort1>5060</sipPort1> 
<sipIpAddr2></sipIpAddr2> 
<sipPort2>5060</sipPort2> 
<sipIpAddr3></sipIpAddr3> 
<sipPort3>5060</sipPort3> 
<isSecure>false</isSecure> 
</srstInfo> 
<mlppDomainId>000000</mlppDomainId> 
<mlppIndicationStatus>Off</mlppIndicationStatus> 
<preemption>Disabled</preemption> 
<connectionMonitorDuration>120</connectionMonitorDuration> 
</devicePool> 
<TVS> 
<members> 
<member  priority="0"> 
<port>2445</port> 
<address>CUCM8</address> 
</member> 
</members> 
</TVS> 
<vpnGroup> 
<mtu>1290</mtu> 
<failConnectTime>30</failConnectTime> 
<authMethod>0</authMethod> 
<pswdPersistent>1</pswdPersistent> 
<autoNetDetect>0</autoNetDetect> 
<enableHostIDCheck>0</enableHostIDCheck> 
<addresses> 
<url1>https://195.101.175.26/phonevpn</url1> 
</addresses> 
<credentials> 
<hashAlg>0</hashAlg> 
<certHash1>EQvLYFYiODVYjWS7pIAjU30EvQs=</certHash1> 
</credentials> 
</vpnGroup> 
<MissedCallLoggingOption>10</MissedCallLoggingOption> 
<commonProfile> 
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<phonePassword></phonePassword> 
<backgroundImageAccess>true</backgroundImageAccess> 
<callLogBlfEnabled>2</callLogBlfEnabled> 
</commonProfile> 
<loadInformation>SCCP75.9-2-1S</loadInformation> 
<vendorConfig> 
<disableSpeaker>false</disableSpeaker><disableSpeakerAndHeadset>false</disableSpeak
erAndHeadset><forwardingDelay>1</forwardingDelay><pcPort>0</pcPort><garp>1</garp>
<voiceVlanAccess>0</voiceVlanAccess><videoCapability>1</videoCapability><autoSelectLi
neEnable>0</autoSelectLineEnable><spanToPCPort>1</spanToPCPort><loggingDisplay>1
</loggingDisplay><recordingTone>0</recordingTone><recordingToneLocalVolume>100</re
cordingToneLocalVolume><recordingToneRemoteVolume>50</recordingToneRemoteVolum
e><recordingToneDuration></recordingToneDuration><displayOnWhenIncomingCall>0</dis
playOnWhenIncomingCall><moreKeyReversionTimer>5</moreKeyReversionTimer><autoC
allSelect>1</autoCallSelect><logServer></logServer><g722CodecSupport>0</g722CodecS
upport><headsetWidebandUIControl>0</headsetWidebandUIControl><headsetWidebandEn
able>0</headsetWidebandEnable><lldpAssetId></lldpAssetId><powerPriority>0</powerPrio
rity><ehookEnable>0</ehookEnable><ipv6LogServer></ipv6LogServer><detectCMConnecti
onFailure>0</detectCMConnectionFailure><minimumRingVolume>0</minimumRingVolume
><webProtocol>0</webProtocol><handsetHeadsetMonitor>0</handsetHeadsetMonitor><us
eEnblocDialing>1</useEnblocDialing></vendorConfig> 
<commonConfig> 
<bluetoothProfile>1</bluetoothProfile><ciscoCamera>1</ciscoCamera><videoCapability>1<
/videoCapability><eapAuthentication>1</eapAuthentication><webProtocol>0</webProtocol>
<webAccess>0</webAccess><sshAccess>1</sshAccess><appInstallFromAndroidMarket>tr
ue</appInstallFromAndroidMarket><presenceServerPri>192.168.100.8</presenceServerPri
><presenceServerType>1</presenceServerType></commonConfig> 
<enterpriseConfig> 
<ciscoCamera>1</ciscoCamera><videoCapability>1</videoCapability><webAccess>0</web
Access><rtcp>1</rtcp><peerFirmwareSharing>1</peerFirmwareSharing><webProtocol>0</
webProtocol></enterpriseConfig> 
<versionStamp>1322487735-82fdecc1-468f-4719-9076-49db07415bae</versionStamp> 
<userLocale> 
<name>French_France</name> 
<uid>2</uid> 
<langCode>fr_FR</langCode> 
<version></version> 
<winCharSet>iso-8859-1</winCharSet> 
</userLocale> 
<networkLocale>United_States</networkLocale> 
<networkLocaleInfo> 
<name>United_States</name> 
<uid>64</uid> 
<version>8.5.0.0(1)</version> 
</networkLocaleInfo> 
<deviceSecurityMode>1</deviceSecurityMode> 
<idleTimeout>0</idleTimeout> 
<authenticationURL>http://CUCM8:8080/ccmcip/authenticate.jsp</authenticationURL> 
<directoryURL>http://CUCM8:8080/ccmcip/xmldirectory.jsp</directoryURL> 
<idleURL></idleURL> 
<informationURL>http://CUCM8:8080/ccmcip/GetTelecasterHelpText.jsp</informationURL> 
<messagesURL></messagesURL> 
<proxyServerURL></proxyServerURL> 
<servicesURL>http://CUCM8:8080/ccmcip/getservicesmenu.jsp</servicesURL> 
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<secureAuthenticationURL>https://CUCM8:8443/ccmcip/authenticate.jsp</secureAuthenticat
ionURL> 
<secureDirectoryURL>https://CUCM8:8443/ccmcip/xmldirectory.jsp</secureDirectoryURL> 
<secureIdleURL></secureIdleURL> 
<secureInformationURL>https://CUCM8:8443/ccmcip/GetTelecasterHelpText.jsp</secureInf
ormationURL> 
<secureMessagesURL></secureMessagesURL> 
<secureServicesURL>https://CUCM8:8443/ccmcip/getservicesmenu.jsp</secureServicesUR
L> 
<dscpForSCCPPhoneConfig>96</dscpForSCCPPhoneConfig> 
<dscpForSCCPPhoneServices>0</dscpForSCCPPhoneServices> 
<dscpForCm2Dvce>96</dscpForCm2Dvce> 
<transportLayerProtocol>1</transportLayerProtocol> 
<dndCallAlert>5</dndCallAlert> 
<phonePersonalization>1</phonePersonalization> 
<rollover>0</rollover> 
<singleButtonBarge>0</singleButtonBarge> 
<joinAcrossLines>0</joinAcrossLines> 
<autoCallPickupEnable>false</autoCallPickupEnable> 
<blfAudibleAlertSettingOfIdleStation>0</blfAudibleAlertSettingOfIdleStation> 
<blfAudibleAlertSettingOfBusyStation>0</blfAudibleAlertSettingOfBusyStation> 
<capfAuthMode>0</capfAuthMode> 
<capfList> 
<capf> 
<phonePort>3804</phonePort> 
<processNodeName>CUCM8</processNodeName> 
</capf> 
</capfList> 
<certHash>62d188d30fc647896ee5085726c6d55d</certHash> 
<encrConfig>false</encrConfig> 
<advertiseG722Codec>1</advertiseG722Codec> 
<mobility> 
<handoffdn>99</handoffdn> 
<dtmfdn>0140033737</dtmfdn> 
<ivrdn>3737</ivrdn> 
<dtmfHoldCode>*81</dtmfHoldCode> 
<dtmfExclusiveHoldCode>*82</dtmfExclusiveHoldCode> 
<dtmfResumeCode>*83</dtmfResumeCode> 
<dtmfTxfCode>*84</dtmfTxfCode> 
<dtmfCnfCode>*85</dtmfCnfCode> 
</mobility> 
<userId>jldarbonnel</userId> 
<phoneServices  useHTTPS="true"> 
<provisioning>0</provisioning> 
<phoneService  type="1" category="0"> 
<name>Missed Calls</name> 
<url>Application:Cisco/MissedCalls</url> 
<vendor></vendor> 
<version></version> 
</phoneService> 
<phoneService  type="1" category="0"> 
<name>Received Calls</name> 
<url>Application:Cisco/ReceivedCalls</url> 
<vendor></vendor> 
<version></version> 
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</phoneService> 
<phoneService  type="1" category="0"> 
<name>Placed Calls</name> 
<url>Application:Cisco/PlacedCalls</url> 
<vendor></vendor> 
<version></version> 
</phoneService> 
<phoneService  type="1" category="0"> 
<name>Personal Directory</name> 
<url>Application:Cisco/PersonalDirectory</url> 
<vendor></vendor> 
<version></version> 
</phoneService> 
<phoneService  type="1" category="0"> 
<name>Corporate Directory</name> 
<url>Application:Cisco/CorporateDirectory</url> 
<vendor></vendor> 
<version></version> 
</phoneService> 
<phoneService  type="0" category="0"> 
<displayName>Cisco Unified MeetingPlace</displayName> 
<name>Cisco Unified MeetingPlace</name> 
<url>http://192.168.100.60/ipphone/MPAPI/ipphone/login?serverhost=192.168.100.60&amp;i
pphone=3733&amp;name=jldarbonnel&amp;wfpassword=12345</url> 
<vendor></vendor> 
<version></version> 
</phoneService> 
<phoneService  type="0" category="0"> 
<displayName>PhoneMessenger</displayName> 
<name>PhoneMessenger</name> 
<url>http://cup8.fremecourt.com:8081/ippm/default?name=#DEVICENAME#</url> 
<vendor></vendor> 
<version></version> 
</phoneService> 
<phoneService  type="0" category="0"> 
<displayName>Sytadin</displayName> 
<name>ANDTEK</name> 
<url>http://192.168.100.10/sytadin</url> 
<vendor></vendor> 
<version></version> 
</phoneService> 
<phoneService  type="0" category="1"> 
<displayName>VisualVoicemail</displayName> 
<name>VisualVoicemail</name> 
<url>http://192.168.100.46/midlets/VisualVoicemail/VisualVoicemail.jad?call_connect_delay=
1000&amp;log_level=info&amp;voicemail_server=192.168.100.46</url> 
<vendor>Cisco</vendor> 
<version></version> 
</phoneService> 
</phoneServices> 
</device> 
 
 


